import re
regex = re.compile(r"\b((?:\w+(?:'\w+)?)(?:-(?:\w+(?:'\w+)?))*)\b", flags=re.MULTILINE | re.UNICODE)
test_str = ("aguardaram-se\n"
"guarda-chuva\n"
"gota-d'água\n"
"d'água\n"
"água\n"
"teste\n"
"-\n"
"a_b\n"
"123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")