# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([a-z]+)(\.)(?:(\d+)(.*))?/$1 $3/gim;t' <<< "one.2021.spurious.other.information.true
one.two.2022.spurious.other.information.true
one.two.three.2023.spurious.other.information.true
one.two.three.four.2024.spurious.other.information.true
one.two.three.four.five.2025.spurious.other.information.true "