package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)([a-z]+)(\.)(?:(\d+)(.*))?`)
var str = `one.2021.spurious.other.information.true
one.two.2022.spurious.other.information.true
one.two.three.2023.spurious.other.information.true
one.two.three.four.2024.spurious.other.information.true
one.two.three.four.five.2025.spurious.other.information.true `
var substitution = "$1 $3"
fmt.Println(re.ReplaceAllString(str, substitution))
}