import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z]+)(\\.)(?:(\\d+)(.*))?";
final String string = "one.2021.spurious.other.information.true\n"
+ "one.two.2022.spurious.other.information.true\n"
+ "one.two.three.2023.spurious.other.information.true\n"
+ "one.two.three.four.2024.spurious.other.information.true\n"
+ "one.two.three.four.five.2025.spurious.other.information.true ";
final String subst = "$1 $3";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}