use strict;
my $str = 'one.2021.spurious.other.information.true
one.two.2022.spurious.other.information.true
one.two.three.2023.spurious.other.information.true
one.two.three.four.2024.spurious.other.information.true
one.two.three.four.five.2025.spurious.other.information.true ';
my $regex = qr/([a-z]+)(\.)(?:(\d+)(.*))?/imp;
my $subst = '$1 $3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";