$re = '/([a-z]+)(\.)(?:(\d+)(.*))?/im';
$str = 'one.2021.spurious.other.information.true
one.two.2022.spurious.other.information.true
one.two.three.2023.spurious.other.information.true
one.two.three.four.2024.spurious.other.information.true
one.two.three.four.five.2025.spurious.other.information.true ';
$subst = "$1 $3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;