import Foundation
let pattern = #"([a-z]+)(\.)(?:(\d+)(.*))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
one.2021.spurious.other.information.true
one.two.2022.spurious.other.information.true
one.two.three.2023.spurious.other.information.true
one.two.three.four.2024.spurious.other.information.true
one.two.three.four.five.2025.spurious.other.information.true
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)