using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z]+)(\.)(?:(\d+)(.*))?";
string substitution = @"$1 $3";
string input = @"one.2021.spurious.other.information.true
one.two.2022.spurious.other.information.true
one.two.three.2023.spurious.other.information.true
one.two.three.four.2024.spurious.other.information.true
one.two.three.four.five.2025.spurious.other.information.true ";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}