#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)([a-z]+)(\.)(?:(\d+)(.*))?"
Local $sString = "one.2021.spurious.other.information.true" & @CRLF & _
"one.two.2022.spurious.other.information.true" & @CRLF & _
"one.two.three.2023.spurious.other.information.true" & @CRLF & _
"one.two.three.four.2024.spurious.other.information.true" & @CRLF & _
"one.two.three.four.five.2025.spurious.other.information.true "
Local $sSubst = "$1 $3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)