package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)de([\-_][A-Z]{2})*\Z`)
var str = `de
de-DE
de_DE
de_CH
de-CH
dd-WR
de-LONGWRONG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}