re = /de([\-_][A-Z]{2})*\Z/m
str = 'de
de-DE
de_DE
de_CH
de-CH
dd-WR
de-LONGWRONG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end