$re = '/de([\-_][A-Z]{2})*\Z/m';
$str = 'de
de-DE
de_DE
de_CH
de-CH
dd-WR
de-LONGWRONG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);