const regex = /de([\-_][A-Z]{2})*\Z/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('de([\\-_][A-Z]{2})*\\Z', 'gm')
const str = `de
de-DE
de_DE
de_CH
de-CH
dd-WR
de-LONGWRONG`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}