import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "de([\\-_][A-Z]{2})*\\Z";
final String string = "de\n"
+ "de-DE\n"
+ "de_DE\n"
+ "de_CH\n"
+ "de-CH\n"
+ "dd-WR\n"
+ "de-LONGWRONG";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}