#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/books(\/(.*))?$"
Local $sString = "/books" & @CRLF & _
"/books/economic-genious" & @CRLF & _
"/books/flight-mechanics" & @CRLF & _
"/books123" & @CRLF & _
"/books/abc/test"
Local $sSubst = "/ebooks$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)