$re = '/\/books(\/(.*))?$/m';
$str = '/books
/books/economic-genious
/books/flight-mechanics
/books123
/books/abc/test';
$subst = "/ebooks$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;