package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/books(\/(.*))?$`)
var str = `/books
/books/economic-genious
/books/flight-mechanics
/books123
/books/abc/test`
var substitution = "/ebooks$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}