import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/books(\\/(.*))?$";
final String string = "/books\n"
+ "/books/economic-genious\n"
+ "/books/flight-mechanics\n"
+ "/books123\n"
+ "/books/abc/test";
final String subst = "/ebooks$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}