using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/books(\/(.*))?$";
string substitution = @"/ebooks$1";
string input = @"/books
/books/economic-genious
/books/flight-mechanics
/books123
/books/abc/test";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}