import Foundation
let pattern = #"\/books(\/(.*))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/books
/books/economic-genious
/books/flight-mechanics
/books123
/books/abc/test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/ebooks$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)