const regex = /\/books(\/(.*))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/books(\\\/(.*))?$', 'gm')
const str = `/books
/books/economic-genious
/books/flight-mechanics
/books123
/books/abc/test`;
const subst = `/ebooks$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);