#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([a-zA-Z][a-zA-Z_]*\.[a-zA-Z]+)"
Local $sString = "1231231223123131_FILE_NAME.EXTENSION.OTHEREXTENSION" & @CRLF & _
"1_This_is_an_otherExample.mpg.OTHEREXTENSIONadasdassdassds34" & @CRLF & _
"1231231223123131_myFile.tar.gz2"
Local $sSubst = "\1.\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)