package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z][a-zA-Z_]*\.[a-zA-Z]+)`)
var str = `1231231223123131_FILE_NAME.EXTENSION.OTHEREXTENSION
1_This_is_an_otherExample.mpg.OTHEREXTENSIONadasdassdassds34
1231231223123131_myFile.tar.gz2`
var substitution = "\1.\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}