import Foundation
let pattern = #"([a-zA-Z][a-zA-Z_]*\.[a-zA-Z]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1231231223123131_FILE_NAME.EXTENSION.OTHEREXTENSION
1_This_is_an_otherExample.mpg.OTHEREXTENSIONadasdassdassds34
1231231223123131_myFile.tar.gz2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1.\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)