import re
regex = re.compile(r"([a-zA-Z][a-zA-Z_]*\.[a-zA-Z]+)", flags=re.MULTILINE)
test_str = ("1231231223123131_FILE_NAME.EXTENSION.OTHEREXTENSION\n"
"1_This_is_an_otherExample.mpg.OTHEREXTENSIONadasdassdassds34\n"
"1231231223123131_myFile.tar.gz2")
subst = "\\1.\\2"
result = regex.sub(subst, test_str)
if result:
print(result)