import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z][a-zA-Z_]*\\.[a-zA-Z]+)";
final String string = "1231231223123131_FILE_NAME.EXTENSION.OTHEREXTENSION\n"
+ "1_This_is_an_otherExample.mpg.OTHEREXTENSIONadasdassdassds34\n"
+ "1231231223123131_myFile.tar.gz2";
final String subst = "\\1.\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}