const regex = new RegExp('([a-zA-Z][a-zA-Z_]*\\.[a-zA-Z]+)', 'gm')
const str = `1231231223123131_FILE_NAME.EXTENSION.OTHEREXTENSION
1_This_is_an_otherExample.mpg.OTHEREXTENSIONadasdassdassds34
1231231223123131_myFile.tar.gz2`;
const subst = `\1.\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);