$re = '/([a-zA-Z][a-zA-Z_]*\.[a-zA-Z]+)/m';
$str = '1231231223123131_FILE_NAME.EXTENSION.OTHEREXTENSION
1_This_is_an_otherExample.mpg.OTHEREXTENSIONadasdassdassds34
1231231223123131_myFile.tar.gz2';
$subst = "\1.\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;