package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/([^\/]+)\/es(\/|$)`)
var str = `http://localhost:3000/es
http://localhost:3000/es/
http://localhost:3000/es/some-post
https://my-site.com/es
https://my-site.com/es/
https://my-site.com/es/some-post
https://random-domain.something/es
https://random-domain.something/es/
https://random-domain.something/es/some-post
http://localhost:3000
http://localhost:3000/
http://localhost:3000/some-post
http://localhost:3000/es-some-post
https://my-site.com
https://my-site.com/
https://my-site.com/some-post
https://my-site.com/es-some-post
https://www.random-domain.something
https://www.random-domain.something/
https://www.random-domain.something/some-post
https://www.random-domain.something/es-some-post`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}