import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/([^\\/]+)\\/es(\\/|$)";
final String string = "http://localhost:3000/es\n"
+ "http://localhost:3000/es/\n"
+ "http://localhost:3000/es/some-post\n"
+ "https://my-site.com/es\n"
+ "https://my-site.com/es/\n"
+ "https://my-site.com/es/some-post\n"
+ "https://random-domain.something/es\n"
+ "https://random-domain.something/es/\n"
+ "https://random-domain.something/es/some-post\n\n"
+ "http://localhost:3000\n"
+ "http://localhost:3000/\n"
+ "http://localhost:3000/some-post\n"
+ "http://localhost:3000/es-some-post\n"
+ "https://my-site.com\n"
+ "https://my-site.com/\n"
+ "https://my-site.com/some-post\n"
+ "https://my-site.com/es-some-post\n"
+ "https://www.random-domain.something\n"
+ "https://www.random-domain.something/\n"
+ "https://www.random-domain.something/some-post\n"
+ "https://www.random-domain.something/es-some-post";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}