# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^"]|^)(Level\s+\d+)([^"]|$)/\1"\2"\3/gm;t' <<< "Level 2 He is Level 2 but not Level 2 ss \"Level 5 but he may be \"Level 2\" but Level 8\" too Level 2"