// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([^"]|^)(Level\s+\d+)([^"]|$)"#).unwrap();
let string = "Level 2 He is Level 2 but not Level 2 ss \"Level 5 but he may be \"Level 2\" but Level 8\" too Level 2";
let substitution = "\\1\"\\2\"\\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}