# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([^\"]|^)(Level\s+\d+)([^\"]|$)"
test_str = "Level 2 He is Level 2 but not Level 2 ss \"Level 5 but he may be \"Level 2\" but Level 8\" too Level 2"
subst = "\\1\"\\2\"\\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.