package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^"]|^)(Level\s+\d+)([^"]|$)`)
var str = `Level 2 He is Level 2 but not Level 2 ss "Level 5 but he may be "Level 2" but Level 8" too Level 2`
var substitution = "\1"\2"\3"
fmt.Println(re.ReplaceAllString(str, substitution))
}