$re = '/([^"]|^)(Level\s+\d+)([^"]|$)/m';
$str = 'Level 2 He is Level 2 but not Level 2 ss "Level 5 but he may be "Level 2" but Level 8" too Level 2';
$subst = "\1\"\2\"\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;