use strict;
my $str = 'Level 2 He is Level 2 but not Level 2 ss "Level 5 but he may be "Level 2" but Level 8" too Level 2';
my $regex = qr/([^"]|^)(Level\s+\d+)([^"]|$)/mp;
my $subst = '\\1"\\2"\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";