const regex = /([^"]|^)(Level\s+\d+)([^"]|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^"]|^)(Level\\s+\\d+)([^"]|$)', 'gm')
const str = `Level 2 He is Level 2 but not Level 2 ss "Level 5 but he may be "Level 2" but Level 8" too Level 2`;
const subst = `\1"\2"\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);