re = /([^"]|^)(Level\s+\d+)([^"]|$)/m
str = 'Level 2 He is Level 2 but not Level 2 ss "Level 5 but he may be "Level 2" but Level 8" too Level 2'
subst = '\\1"\\2"\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result