# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.COM|(?<![A-Z]{2}) (?![A-Z]{2})|[.&,]| (?>)&//gm;t' <<< "W. & J. JOHNSON LMT.COM
NORTH ROOF & WORKS CO. LTD.
DAVID DOE & CO., LIMITED
GEORGE TV & APPLIANCE LTD.
LOVE BROS. & OTHERS LTD.
A. B. & MICHAEL CLEAN CO. LTD.
C.M. & B.B. CLEANER INC."