use strict;
my $str = 'W. & J. JOHNSON LMT.COM
NORTH ROOF & WORKS CO. LTD.
DAVID DOE & CO., LIMITED
GEORGE TV & APPLIANCE LTD.
LOVE BROS. & OTHERS LTD.
A. B. & MICHAEL CLEAN CO. LTD.
C.M. & B.B. CLEANER INC.';
my $regex = qr/\.COM|(?<![A-Z]{2}) (?![A-Z]{2})|[.&,]| (?>)&/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";