re = /\.COM|(?<![A-Z]{2}) (?![A-Z]{2})|[.&,]| (?>)&/m
str = 'W. & J. JOHNSON LMT.COM
NORTH ROOF & WORKS CO. LTD.
DAVID DOE & CO., LIMITED
GEORGE TV & APPLIANCE LTD.
LOVE BROS. & OTHERS LTD.
A. B. & MICHAEL CLEAN CO. LTD.
C.M. & B.B. CLEANER INC.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result