# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\.COM|(?<![A-Z]{2}) (?![A-Z]{2})|[.&,]| (?>)&"
test_str = ("W. & J. JOHNSON LMT.COM\n"
"NORTH ROOF & WORKS CO. LTD.\n"
"DAVID DOE & CO., LIMITED\n"
"GEORGE TV & APPLIANCE LTD.\n"
"LOVE BROS. & OTHERS LTD.\n"
"A. B. & MICHAEL CLEAN CO. LTD.\n"
"C.M. & B.B. CLEANER INC.")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.