using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.COM|(?<![A-Z]{2}) (?![A-Z]{2})|[.&,]| (?>)&";
string substitution = @"";
string input = @"W. & J. JOHNSON LMT.COM
NORTH ROOF & WORKS CO. LTD.
DAVID DOE & CO., LIMITED
GEORGE TV & APPLIANCE LTD.
LOVE BROS. & OTHERS LTD.
A. B. & MICHAEL CLEAN CO. LTD.
C.M. & B.B. CLEANER INC.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}