$re = '/\.COM|(?<![A-Z]{2}) (?![A-Z]{2})|[.&,]| (?>)&/m';
$str = 'W. & J. JOHNSON LMT.COM
NORTH ROOF & WORKS CO. LTD.
DAVID DOE & CO., LIMITED
GEORGE TV & APPLIANCE LTD.
LOVE BROS. & OTHERS LTD.
A. B. & MICHAEL CLEAN CO. LTD.
C.M. & B.B. CLEANER INC.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;