const regex = /\.COM|(?<![A-Z]{2}) (?![A-Z]{2})|[.&,]| (?>)&/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.COM|(?<![A-Z]{2}) (?![A-Z]{2})|[.&,]| (?>)&', 'gm')
const str = `W. & J. JOHNSON LMT.COM
NORTH ROOF & WORKS CO. LTD.
DAVID DOE & CO., LIMITED
GEORGE TV & APPLIANCE LTD.
LOVE BROS. & OTHERS LTD.
A. B. & MICHAEL CLEAN CO. LTD.
C.M. & B.B. CLEANER INC.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);