#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.COM|(?<![A-Z]{2}) (?![A-Z]{2})|[.&,]| (?>)&"
Local $sString = "W. & J. JOHNSON LMT.COM" & @CRLF & _
"NORTH ROOF & WORKS CO. LTD." & @CRLF & _
"DAVID DOE & CO., LIMITED" & @CRLF & _
"GEORGE TV & APPLIANCE LTD." & @CRLF & _
"LOVE BROS. & OTHERS LTD." & @CRLF & _
"A. B. & MICHAEL CLEAN CO. LTD." & @CRLF & _
"C.M. & B.B. CLEANER INC."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)