# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img src=".*?\\/([A-Z0-9]+)\.\w+"\s*\\/><img src=".*?\\/([A-Z0-9]+)\.\w+"\s*\\/>/&#x$1; &#x$2;/gm;t' <<< "<img src=\"http://www.example.com/app_res/emoji/1F60A.png\" /><img src=\"http://www.example.com/app_res/emoji/1F389.png\" />
<img src=\"http://www.example.com/app_res/emoji/1F61E.png\" /><img src=\"http://www.example.com/app_res/emoji/1F339.png\" />"