// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<img src=".*?\/([A-Z0-9]+)\.\w+"\s*\/><img src=".*?\/([A-Z0-9]+)\.\w+"\s*\/>"#).unwrap();
let string = "<img src=\"http://www.example.com/app_res/emoji/1F60A.png\" /><img src=\"http://www.example.com/app_res/emoji/1F389.png\" />
<img src=\"http://www.example.com/app_res/emoji/1F61E.png\" /><img src=\"http://www.example.com/app_res/emoji/1F339.png\" />";
let substitution = "&#x$1; &#x$2;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}