import re
regex = re.compile(r"<img src=\".*?\/([A-Z0-9]+)\.\w+\"\s*\/><img src=\".*?\/([A-Z0-9]+)\.\w+\"\s*\/>", flags=re.MULTILINE)
test_str = ("<img src=\"http://www.example.com/app_res/emoji/1F60A.png\" /><img src=\"http://www.example.com/app_res/emoji/1F389.png\" />\n"
"<img src=\"http://www.example.com/app_res/emoji/1F61E.png\" /><img src=\"http://www.example.com/app_res/emoji/1F339.png\" />")
subst = "&#x$1; &#x$2;"
result = regex.sub(subst, test_str)
if result:
print(result)