using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img src="".*?\/([A-Z0-9]+)\.\w+""\s*\/><img src="".*?\/([A-Z0-9]+)\.\w+""\s*\/>";
string substitution = @"&#x$1; &#x$2;";
string input = @"<img src=""http://www.example.com/app_res/emoji/1F60A.png"" /><img src=""http://www.example.com/app_res/emoji/1F389.png"" />
<img src=""http://www.example.com/app_res/emoji/1F61E.png"" /><img src=""http://www.example.com/app_res/emoji/1F339.png"" />";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}